I’m shiny and white. That’s all

In ubuntu to install all the reqs for neuronvisio you have to type:

sudo apt-get install python-numpy python-gtk2 python-visual python-matplotlib

and you ready to go. On the other systems, like Mac or windows you have to run for every package by yourself, making your life more complicated.

This is a fact. November 2009.

4 Comments

  1. exactly, this is one of the reason why I like Linux operating systems in general.

    Anyway, many people prefer to use enthought (http://www.enthought.com/products/epd.php) which is basically an enhanced version of numpy+scipy+matplotlib from the authors of these packages. Probably if you want to install neuronvision, you can install enthought and it should have all those dependencies already.

    • I don’t see the point to install the enthought distribution. Scipy numpy and matplotilib are all available under linux (Ubuntu in the specific) with no problem at all.

      They are also available for Mac and Windows, it’s just a lot of headache.

      Linux is the easiest system ever for this case.

  2. I still had to jump through a few hoops to get things running on my 64 bit AMD machine.. Getting a Macbook soon, not looking forward to getting scipy working there :S

Leave a Reply

© 2020 Train of Thoughts

Theme by Anders NorénUp ↑

By continuing to use the site (scrolling or clicking counts), you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close